{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-3155 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-3155 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 17 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3155 and fix it if it is affected.\n\nWhat it is: CVE-2021-3155 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 17 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3155 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3155/ (Markdown: https://insights.sbomify.com/CVE-2021-3155/index.md)","id":"CVE-2021-3155","markdown":"https://insights.sbomify.com/CVE-2021-3155/index.md","name":"CVE-2021-3155","record":{"aliases":["DEBIAN-CVE-2021-3155","GHSA-7x7f-q6wr-wc4w","UBUNTU-CVE-2021-3155"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux package manager","requires_auth":"low_privilege","summary":"Local attackers can read private information from snap directories due to overly permissive default permissions in snapd.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"snapd","vendor":"canonical"},{"product":"ubuntu_linux","vendor":"canonical"}],"cvss":{"score":3.8,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"snapd 2.54.2 and earlier created ~/snap directories in user home directories without specifying owner-only permissions. This could allow a local attacker to read information that should have been private. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"snapd created ~/snap with too-wide permissions","id":"CVE-2021-3155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"misconfiguration","year":"2021"},"n_packages":0,"n_references":3,"next":{"headline":"Sudo Heap-Based Buffer Overflow","id":"CVE-2021-3156"},"packages":[],"prev":{"headline":"Code injection in n/a","id":"CVE-2021-3154"},"products":["snapd"],"published":"2022-02-17","related":[{"cvss_score":10,"headline":"Command injection in snapd","id":"CVE-2023-1523","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.3,"headline":"Privilege escalation in snapd","id":"CVE-2020-27352","kev_date_added":null,"published":"2024-06-21"},{"cvss_score":8.8,"headline":"Local privilege escalation via snapd socket","id":"CVE-2019-7304","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":8.2,"headline":"snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths","id":"CVE-2021-4120","kev_date_added":null,"published":"2022-02-17"},{"cvss_score":8.1,"headline":"CVE-2024-5138: snapd snapctl auth bypass","id":"CVE-2024-5138","kev_date_added":null,"published":"2024-05-31"},{"cvss_score":7.8,"headline":"snapd Race Condition vulnerability","id":"CVE-2022-3328","kev_date_added":null,"published":"2024-01-08"},{"cvss_score":7.8,"headline":"snapd could be made to escalate privileges and run programs as administrator","id":"CVE-2021-44730","kev_date_added":null,"published":"2022-02-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Canonical Ltd."]},"summary":"Local attackers can read private information from snap directories due to overly permissive default permissions in snapd.","url":"https://insights.sbomify.com/CVE-2021-3155/"}