# CVE-2021-3155: snapd created ~/snap with too-wide permissions

> Local attackers can read private information from snap directories due to overly permissive default permissions in snapd.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-3155, GHSA-7x7f-q6wr-wc4w, UBUNTU-CVE-2021-3155

## What is CVE-2021-3155?

CVE-2021-3155 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 17 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

snapd 2.54.2 and earlier created ~/snap directories in user home directories without specifying owner-only permissions. This could allow a local attacker to read information that should have been private. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2021-3155?

It affects 2 products.


Products: Canonical Snapd, Canonical Ubuntu Linux.

## How do I fix CVE-2021-3155?

Upgrade to a fixed version.

## Is CVE-2021-3155 being exploited?

There is no known exploitation of CVE-2021-3155 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2023-1523](https://insights.sbomify.com/CVE-2023-1523/): Command injection in snapd (critical 10.0)
- [CVE-2020-27352](https://insights.sbomify.com/CVE-2020-27352/): Privilege escalation in snapd (critical 9.3)
- [CVE-2019-7304](https://insights.sbomify.com/CVE-2019-7304/): Local privilege escalation via snapd socket (high 8.8)
- [CVE-2021-4120](https://insights.sbomify.com/CVE-2021-4120/): snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths (high 8.2)
- [CVE-2024-5138](https://insights.sbomify.com/CVE-2024-5138/): CVE-2024-5138: snapd snapctl auth bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3155 and fix it if it is affected.

What it is: CVE-2021-3155 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 17 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3155 in the wild and no public exploit code.

Affected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3155/ (Markdown: https://insights.sbomify.com/CVE-2021-3155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3155
- OSV: https://osv.dev/vulnerability/CVE-2021-3155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3155/
Summaries are generated and may contain mistakes; the official description above is the record.
