# CVE-2021-31551: Cross-site scripting in n/a

> Crafted payloads in Token query parameters allow XSS on MediaWiki pages managed by the PageForms extension.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-mediawiki-2021-31551, GHSA-vf5h-f8r3-vj4x

## What is CVE-2021-31551?

CVE-2021-31551 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 22 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the PageForms extension for MediaWiki through 1.35.2. Crafted payloads for Token-related query parameters allowed for XSS on certain PageForms-managed MediaWiki pages.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-31551?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.3 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2021-31551?

Upgrade mediawiki to 1.35.3 or later.

## Is CVE-2021-31551 being exploited?

There is no known exploitation of CVE-2021-31551 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31551 and fix it if it is affected.

What it is: CVE-2021-31551 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 22 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-31551 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31551/ (Markdown: https://insights.sbomify.com/CVE-2021-31551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31551
- OSV: https://osv.dev/vulnerability/CVE-2021-31551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31551/
Summaries are generated and may contain mistakes; the official description above is the record.
