# CVE-2021-31554: Auth bypass in n/a

> Attackers can bypass account blocks in MediaWiki's AbuseFilter extension, allowing malicious users to remain active despite being blocked.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-mediawiki-2021-31554, GHSA-j4g8-vqq3-7h58

## What is CVE-2021-31554?

CVE-2021-31554 is a medium-severity authentication bypass vulnerability in Mediawiki Mediawiki, published on 22 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in the AbuseFilter extension for MediaWiki through 1.35.2. It improperly handled account blocks for certain automatically created MediaWiki user accounts, thus allowing nefarious users to remain unblocked.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-31554?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.3 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2021-31554?

Upgrade mediawiki to 1.35.3 or later.

## Is CVE-2021-31554 being exploited?

There is no known exploitation of CVE-2021-31554 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31554 and fix it if it is affected.

What it is: CVE-2021-31554 is a medium-severity authentication bypass vulnerability in Mediawiki Mediawiki, published on 22 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31554 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31554/ (Markdown: https://insights.sbomify.com/CVE-2021-31554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31554
- OSV: https://osv.dev/vulnerability/CVE-2021-31554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31554/
Summaries are generated and may contain mistakes; the official description above is the record.
