# CVE-2021-31580: Akkadian Provisioning Manager Engine (PME) Shell Escape via 'exec' command

> Attackers can bypass the restricted shell in Akkadian PME by using SSH exec mode to execute arbitrary commands, leading to code execution.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8892-4233-8xfv

## What is CVE-2021-31580?

CVE-2021-31580 is a high-severity command injection vulnerability in Akkadian Provisioning Manager Engine (PME), published on 22 Jul 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The restricted shell provided by Akkadian Provisioning Manager Engine (PME) can be bypassed by switching the OpenSSH channel from `shell` to `exec` and providing the ssh client a single execution parameter. This issue was resolved in Akkadian OVA appliance version 3.0 (and later), Akkadian Provisioning Manager 5.0.2 (and later), and Akkadian Appliance Manager 3.3.0.314-4a349e0 (and later).

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-31580?

It affects 2 products.


Products: Akkadianlabs Ova Appliance, Akkadianlabs Provisioning Manager.

## How do I fix CVE-2021-31580?

No fix has been published for CVE-2021-31580 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-31580 being exploited?

There is no known exploitation of CVE-2021-31580 in the wild and no public exploit code.

## Other vulnerabilities in Akkadian Provisioning Manager Engine (PME)

- [CVE-2021-31579](https://insights.sbomify.com/CVE-2021-31579/): Akkadian Provisioning Manager Engine (PME) Hard-Coded Credentials (high 8.2)
- [CVE-2021-31581](https://insights.sbomify.com/CVE-2021-31581/): Akkadian Provisioning Manager Engine (PME) Shell Escape via 'vi' editor interface (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31580 and fix it if it is affected.

What it is: CVE-2021-31580 is a high-severity command injection vulnerability in Akkadian Provisioning Manager Engine (PME), published on 22 Jul 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31580 in the wild and no public exploit code.

Affected product: Akkadian Provisioning Manager Engine (PME). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31580/ (Markdown: https://insights.sbomify.com/CVE-2021-31580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31580
- OSV: https://osv.dev/vulnerability/CVE-2021-31580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31580/
Summaries are generated and may contain mistakes; the official description above is the record.
