# CVE-2021-31597: Improper Certificate Validation in xmlhttprequest-ssl

> The xmlhttprequest-ssl library disables SSL certificate validation by default, allowing attackers to bypass security checks and intercept encrypted traffic.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-45213, CLSA-2026-1785204344, GHSA-72mh-269x-7mh5, UBUNTU-CVE-2021-31597

## What is CVE-2021-31597?

CVE-2021-31597 is a critical vulnerability in n/a, published on 22 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The xmlhttprequest-ssl package before 1.6.1 for Node.js disables SSL certificate validation by default, because rejectUnauthorized (when the property exists but is undefined) is considered to be false within the https.request function of Node.js. In other words, no certificate is ever rejected.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2021-31597?

2 open source packages ship an affected version, including xmlhttprequest-ssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xmlhttprequest-ssl` | npm | All versions | 1.6.1 |
| `xmlhttprequest-ssl` | npm | All versions | 1.6.1 |

Products: Xmlhttprequest-Ssl Project Xmlhttprequest-Ssl.

## How do I fix CVE-2021-31597?

Upgrade xmlhttprequest-ssl to 1.6.1 or later.

## Is CVE-2021-31597 being exploited?

There is no known exploitation of CVE-2021-31597 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31597 and fix it if it is affected.

What it is: CVE-2021-31597 is a critical vulnerability in n/a, published on 22 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31597 in the wild and no public exploit code.

Affected packages and fixed versions:
- xmlhttprequest-ssl (npm): affected all versions; fixed in 1.6.1
- xmlhttprequest-ssl (npm): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31597/ (Markdown: https://insights.sbomify.com/CVE-2021-31597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31597
- OSV: https://osv.dev/vulnerability/CVE-2021-31597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31597/
Summaries are generated and may contain mistakes; the official description above is the record.
