{"answers":{"affected":"2 open source packages ship an affected version, including pgsync. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-31671 in the wild and no public exploit code.","fix":"Upgrade pgsync to 0.6.7 or later.","what":"CVE-2021-31671 is a high-severity vulnerability in n/a, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-31671 and fix it if it is affected.\n\nWhat it is: CVE-2021-31671 is a high-severity vulnerability in n/a, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-31671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgsync (RubyGems): affected all versions; fixed in 0.6.7\n- pgsync (RubyGems): affected all versions; fixed in 0.6.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-31671/ (Markdown: https://insights.sbomify.com/CVE-2021-31671/index.md)","id":"CVE-2021-31671","markdown":"https://insights.sbomify.com/CVE-2021-31671/index.md","name":"CVE-2021-31671","record":{"aliases":["GHSA-72rj-36qc-47g7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby database sync library","requires_auth":"none","summary":"Attackers can intercept sensitive data because pgsync fails to enforce SSL connections during specific schema synchronization operations.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pgsync","vendor":"pgsync_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"}],"description":"pgsync before 0.6.7 is affected by Information Disclosure of sensitive information. Syncing the schema with the --schema-first and --schema-only options is mishandled. For example, the sslmode connection parameter may be lost, which means that SSL would not be used.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pgsync Contains Cleartext Transmission of Sensitive Information","id":"CVE-2021-31671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-31673"},"packages":[{"ecosystem":"RubyGems","fixed":["0.6.7"],"introduced":["0"],"last_affected":[],"package":"pgsync","purl":null,"source":"GHSA-72rj-36qc-47g7"},{"ecosystem":"RubyGems","fixed":["0.6.7"],"introduced":["0"],"last_affected":[],"package":"pgsync","purl":"pkg:gem/pgsync","source":"GHSA-72rj-36qc-47g7"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2021-31664"},"products":["n/a"],"published":"2021-04-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can intercept sensitive data because pgsync fails to enforce SSL connections during specific schema synchronization operations.","url":"https://insights.sbomify.com/CVE-2021-31671/"}