# CVE-2021-31671: Pgsync Contains Cleartext Transmission of Sensitive Information

> Attackers can intercept sensitive data because pgsync fails to enforce SSL connections during specific schema synchronization operations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-72rj-36qc-47g7

## What is CVE-2021-31671?

CVE-2021-31671 is a high-severity vulnerability in n/a, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pgsync before 0.6.7 is affected by Information Disclosure of sensitive information. Syncing the schema with the --schema-first and --schema-only options is mishandled. For example, the sslmode connection parameter may be lost, which means that SSL would not be used.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2021-31671?

2 open source packages ship an affected version, including pgsync. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgsync` | RubyGems | All versions | 0.6.7 |
| `pgsync` | RubyGems | All versions | 0.6.7 |

Products: Pgsync Project Pgsync.

## How do I fix CVE-2021-31671?

Upgrade pgsync to 0.6.7 or later.

## Is CVE-2021-31671 being exploited?

There is no known exploitation of CVE-2021-31671 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31671 and fix it if it is affected.

What it is: CVE-2021-31671 is a high-severity vulnerability in n/a, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31671 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgsync (RubyGems): affected all versions; fixed in 0.6.7
- pgsync (RubyGems): affected all versions; fixed in 0.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31671/ (Markdown: https://insights.sbomify.com/CVE-2021-31671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31671
- OSV: https://osv.dev/vulnerability/CVE-2021-31671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31671/
Summaries are generated and may contain mistakes; the official description above is the record.
