# CVE-2021-31712: Cross-site Scripting in React Draft Wysiwyg

> An attacker can inject JavaScript via a malicious link target in the React Draft Wysiwyg editor, leading to cross-site scripting when drafts are shared.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qcg2-h349-vwm3

## What is CVE-2021-31712?

CVE-2021-31712 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

react-draft-wysiwyg (aka React Draft Wysiwyg) before 1.14.6 allows a javascript: URi in a Link Target of the link decorator in decorators/Link/index.js when a draft is shared across users, leading to XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-31712?

2 open source packages ship an affected version, including react-draft-wysiwyg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-draft-wysiwyg` | npm | All versions | 1.14.6 |
| `react-draft-wysiwyg` | npm | All versions | 1.14.6 |

Products: React Draft Wysiwyg Project React Draft Wysiwyg.

## How do I fix CVE-2021-31712?

Upgrade react-draft-wysiwyg to 1.14.6 or later.

## Is CVE-2021-31712 being exploited?

There is no known exploitation of CVE-2021-31712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31712 and fix it if it is affected.

What it is: CVE-2021-31712 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-31712 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-draft-wysiwyg (npm): affected all versions; fixed in 1.14.6
- react-draft-wysiwyg (npm): affected all versions; fixed in 1.14.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31712/ (Markdown: https://insights.sbomify.com/CVE-2021-31712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31712
- OSV: https://osv.dev/vulnerability/CVE-2021-31712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31712/
Summaries are generated and may contain mistakes; the official description above is the record.
