# CVE-2021-3177: Memory corruption in n/a

> A buffer overflow in Python's ctypes module allows remote code execution when processing untrusted floating-point numbers.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2021
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2021-3177, BIT-libpython-2021-3177, BIT-python-2021-3177, BIT-python-min-2021-3177, CLEANSTART-2026-FH60481, DEBIAN-CVE-2021-3177, GHSA-hc96-xw56-vfwh, MGASA-2021-0064, OESA-2021-1036, OESA-2021-1066, PSF-2021-3, UBUNTU-CVE-2021-3177, USN-4754-4, USN-4754-5

## What is CVE-2021-3177?

CVE-2021-3177 is a critical memory corruption vulnerability in Debian Debian Linux, published on 19 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2021-3177?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 10 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.8, 3.9.2 |
| `python` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.8, 3.9.2 |
| `python-min` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.8, 3.9.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp Ontap Select Deploy Administration Utility, Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Oracle Communications Offline Mediation Controller, Oracle Communications Pricing Design Center, Oracle Enterprise Manager Ops Center, Oracle Zfs Storage Appliance Kit, Python Python.

## How do I fix CVE-2021-3177?

Upgrade libpython to a fixed version for your release line: 3.6.13, 3.7.10, 3.8.8 or 3.9.2.

## Is CVE-2021-3177 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3177 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3177 and fix it if it is affected.

What it is: CVE-2021-3177 is a critical memory corruption vulnerability in Debian Debian Linux, published on 19 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3177 exists.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.8, 3.9.2
- python (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.8, 3.9.2
- python-min (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.8, 3.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3177/ (Markdown: https://insights.sbomify.com/CVE-2021-3177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3177
- OSV: https://osv.dev/vulnerability/CVE-2021-3177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3177/
Summaries are generated and may contain mistakes; the official description above is the record.
