# CVE-2021-31800: Path traversal in impacket

> Attackers can traverse directories to read or write arbitrary files, potentially achieving code execution by modifying system files like SSH keys.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-31800, GHSA-mj63-64x7-57xf, PYSEC-2021-17, UBUNTU-CVE-2021-31800, openSUSE-SU-2024:11232-1, openSUSE-SU-2024:14142-1

## What is CVE-2021-31800?

CVE-2021-31800 is a critical path traversal vulnerability in Fedoraproject Fedora, published on 5 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple path traversal vulnerabilities exist in smbserver.py in Impacket through 0.9.22. An attacker that connects to a running smbserver instance can list and write to arbitrary files via ../ directory traversal. This could potentially be abused to achieve arbitrary code execution by replacing /etc/shadow or an SSH authorized key.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-31800?

3 open source packages ship an affected version, including impacket. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `impacket` | PyPI | All versions | 0.9.23 |
| `impacket` | PyPI | All versions | 0.9.23 |
| `impacket` | PyPI | From 0.9.10 | 0.9.23 |
| `python-impacket` | openSUSE:Tumbleweed | All versions | 0.11.0-3.3 |

Products: Fedoraproject Fedora, Secureauth Impacket.

## How do I fix CVE-2021-31800?

Upgrade impacket to 0.9.23 or later.

## Is CVE-2021-31800 being exploited?

There is no known exploitation of CVE-2021-31800 in the wild and no public exploit code.

Public exploit code:

- A path traversal in smbserver.py allows an attacker to read/write arbitrary files on the server. (github_poc): https://github.com/p0dalirius/CVE-2021-31800-Impacket-SMB-Server-Arbitrary-file-read-write
- CVE-2021-31800 POC (github_poc): https://github.com/Louzogh/CVE-2021-31800

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31800 and fix it if it is affected.

What it is: CVE-2021-31800 is a critical path traversal vulnerability in Fedoraproject Fedora, published on 5 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31800 in the wild and no public exploit code.

Affected packages and fixed versions:
- impacket (PyPI): affected all versions; fixed in 0.9.23
- impacket (PyPI): affected all versions; fixed in 0.9.23
- impacket (PyPI): affected from 0.9.10; fixed in 0.9.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31800/ (Markdown: https://insights.sbomify.com/CVE-2021-31800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31800
- OSV: https://osv.dev/vulnerability/CVE-2021-31800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31800/
Summaries are generated and may contain mistakes; the official description above is the record.
