# CVE-2021-31805: Forced OGNL evaluation, when evaluated on raw not validated user input in tag attributes, may lead to RCE.

> Attackers can achieve remote code execution by exploiting forced OGNL evaluation on unvalidated user input in specific tag attributes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v8j6-6c2r-r27c

## What is CVE-2021-31805?

CVE-2021-31805 is a critical code injection vulnerability in Apache Struts, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The fix issued for CVE-2020-17530 was incomplete. So from Apache Struts 2.0.0 to 2.5.29, still some of the tag’s attributes could perform a double evaluation if a developer applied forced OGNL evaluation by using the %{...} syntax. Using forced OGNL evaluation on untrusted user input can lead to a Remote Code Execution and security degradation.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2021-31805?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.30 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.30 |

Products: Apache Struts.

## How do I fix CVE-2021-31805?

Upgrade org.apache.struts:struts2-core to 2.5.30 or later.

## Is CVE-2021-31805 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-31805 exists.

Public exploit code:

- 远程代码执行S2-062 CVE-2021-31805验证POC (github_poc): https://github.com/pyroxenites/s2-062
- S2-062 (CVE-2021-31805) / S2-061 / S2-059 RCE (github_poc): https://github.com/Wrin9/CVE-2021-31805
- Apache Struts2 S2-062远程代码执行漏洞(CVE-2021-31805) 支持批量扫描漏洞及漏洞利用 (github_poc): https://github.com/jax7sec/S2-062
- Apache Struts2 S2-062远程代码执行漏洞(CVE-2021-31805) | 反弹Shell (github_poc): https://github.com/SecNN/Struts2_S2-062_CVE-2021-31805
-  PoC for CVE-2021-31805 (Apache Struts2) (github_poc): https://github.com/aeyesec/CVE-2021-31805
- S2-061/S2-062 Struts2 远程命令执行漏洞 POC&EXP (github_poc): https://github.com/z92g/CVE-2021-31805

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31805 and fix it if it is affected.

What it is: CVE-2021-31805 is a critical code injection vulnerability in Apache Struts, published on 12 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-31805 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.30
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31805/ (Markdown: https://insights.sbomify.com/CVE-2021-31805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31805
- OSV: https://osv.dev/vulnerability/CVE-2021-31805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31805/
Summaries are generated and may contain mistakes; the official description above is the record.
