# CVE-2021-31810: Server-side request forgery in n/a

> A malicious FTP server can trick Ruby's Net::FTP into connecting to arbitrary internal addresses, enabling port scans and service banner extraction.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-31810, BIT-ruby-2021-31810, BIT-ruby-min-2021-31810, CLEANSTART-2026-GT10640, DEBIAN-CVE-2021-31810, GHSA-wr95-679j-87v9, JLSEC-2026-1284, UBUNTU-CVE-2021-31810

## What is CVE-2021-31810?

CVE-2021-31810 is a medium-severity server-side request forgery vulnerability in Debian Debian Linux, published on 13 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port. This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions).

## Which versions are affected by CVE-2021-31810?

2 open source packages ship an affected version, including ruby and ruby-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby` | Bitnami | All versions | 2.6.8, 2.7.4, 3.0.2 |
| `ruby-min` | Bitnami | All versions | 2.6.8, 2.7.4, 3.0.2 |

Products: Debian Debian Linux, Oracle Jd Edwards Enterpriseone Tools, Ruby-Lang Ruby.

## How do I fix CVE-2021-31810?

Upgrade ruby to a fixed version for your release line: 2.6.8, 2.7.4 or 3.0.2.

## Is CVE-2021-31810 being exploited?

There is no known exploitation of CVE-2021-31810 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31810 and fix it if it is affected.

What it is: CVE-2021-31810 is a medium-severity server-side request forgery vulnerability in Debian Debian Linux, published on 13 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31810 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby (Bitnami): affected all versions; fixed in 2.6.8, 2.7.4, 3.0.2
- ruby-min (Bitnami): affected all versions; fixed in 2.6.8, 2.7.4, 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31810/ (Markdown: https://insights.sbomify.com/CVE-2021-31810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31810
- OSV: https://osv.dev/vulnerability/CVE-2021-31810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31810/
Summaries are generated and may contain mistakes; the official description above is the record.
