# CVE-2021-31811: A carefully crafted PDF file can trigger an OutOfMemory-Exception while loading a tiny file

> Attackers can cause a denial of service by providing a crafted PDF file that triggers an OutOfMemory exception in Apache PDFBox.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-31811, GHSA-fg3j-q579-v8x4, UBUNTU-CVE-2021-31811

## What is CVE-2021-31811?

CVE-2021-31811 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Jun 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Apache PDFBox, a carefully crafted PDF file can trigger an OutOfMemory-Exception while loading the file. This issue affects Apache PDFBox version 2.0.23 and prior 2.0.x versions.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2021-31811?

4 open source packages ship an affected version, including org.apache.pdfbox:pdfbox and org.apache.pdfbox:pdfbox-parent. It affects 12 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pdfbox:pdfbox` | Maven | From 2.0.0 | 2.0.24 |
| `org.apache.pdfbox:pdfbox` | Maven | From 2.0.0 | 2.0.24 |
| `org.apache.pdfbox:pdfbox-parent` | Maven | From 2.0.0 | 2.0.24 |
| `org.apache.pdfbox:pdfbox-parent` | Maven | From 2.0.0 | 2.0.24 |

Products: Apache Pdfbox, Fedoraproject Fedora, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management, Oracle Banking Supply Chain Finance, Oracle Banking Trade Finance, Oracle Banking Treasury Management, Oracle Communications Messaging Server, Oracle Flexcube Universal Banking, Oracle Outside in Technology, Oracle Primavera Unifier, Oracle Retail Customer Management and Segmentation Foundation.

## How do I fix CVE-2021-31811?

Upgrade org.apache.pdfbox:pdfbox to 2.0.24 or later.

## Is CVE-2021-31811 being exploited?

There is no known exploitation of CVE-2021-31811 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2016-2175](https://insights.sbomify.com/CVE-2016-2175/): High severity vulnerability that affects org.apache.pdfbox:pdfbox (high 7.8)
- [CVE-2018-8036](https://insights.sbomify.com/CVE-2018-8036/): Loop with Unreachable Exit Condition in Apache PDFBox (medium 6.5)
- [CVE-2021-31812](https://insights.sbomify.com/CVE-2021-31812/): A carefully crafted PDF file can trigger an infinite loop while loading the file (medium 5.5)
- [CVE-2021-27807](https://insights.sbomify.com/CVE-2021-27807/): A carefully crafted PDF file can trigger an infinite loop while loading the file (medium 5.5)
- [CVE-2021-27906](https://insights.sbomify.com/CVE-2021-27906/): A carefully crafted PDF file can trigger an OutOfMemory-Exception while loading the file (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31811 and fix it if it is affected.

What it is: CVE-2021-31811 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Jun 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-31811 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pdfbox:pdfbox (Maven): affected from 2.0.0; fixed in 2.0.24
- org.apache.pdfbox:pdfbox (Maven): affected from 2.0.0; fixed in 2.0.24
- org.apache.pdfbox:pdfbox-parent (Maven): affected from 2.0.0; fixed in 2.0.24
- org.apache.pdfbox:pdfbox-parent (Maven): affected from 2.0.0; fixed in 2.0.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31811/ (Markdown: https://insights.sbomify.com/CVE-2021-31811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31811
- OSV: https://osv.dev/vulnerability/CVE-2021-31811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31811/
Summaries are generated and may contain mistakes; the official description above is the record.
