# CVE-2021-31819: Remote Code Execution in Halibut

> A deserialization vulnerability in the Halibut library allows remote code execution on systems that trust each other via certificate verification.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hpf7-4c2g-9chf

## What is CVE-2021-31819?

CVE-2021-31819 is a critical unsafe deserialization vulnerability in Octopus Deploy Halibut, published on 22 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Halibut versions prior to 4.4.7 there is a deserialisation vulnerability that could allow remote code execution on systems that already trust each other based on certificate verification.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-31819?

2 open source packages ship an affected version, including Halibut. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Halibut` | NuGet | All versions | 4.4.7 |
| `Halibut` | NuGet | All versions | 4.4.7 |

Products: Octopus Halibut.

## How do I fix CVE-2021-31819?

Upgrade Halibut to 4.4.7 or later.

## Is CVE-2021-31819 being exploited?

There is no known exploitation of CVE-2021-31819 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31819 and fix it if it is affected.

What it is: CVE-2021-31819 is a critical unsafe deserialization vulnerability in Octopus Deploy Halibut, published on 22 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31819 in the wild and no public exploit code.

Affected packages and fixed versions:
- Halibut (NuGet): affected all versions; fixed in 4.4.7
- Halibut (NuGet): affected all versions; fixed in 4.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31819/ (Markdown: https://insights.sbomify.com/CVE-2021-31819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31819
- OSV: https://osv.dev/vulnerability/CVE-2021-31819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31819/
Summaries are generated and may contain mistakes; the official description above is the record.
