CVE-2021-31863 Path traversal in n/a
Insufficient input validation in Redmine's Git integration allows authenticated users to read arbitrary local files accessible by the server process.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-31863?
CVE-2021-31863 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 28 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
Weakness: CWE-20
Which versions are affected by CVE-2021-31863?
1 open source package ship an affected version, including redmine. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
redmine Bitnami | All versions | 4.0.9, 4.1.3, 4.2.1 |
Products include Debian Debian Linux, Redmine Redmine.
How do I fix CVE-2021-31863?
Upgrade redmine to a fixed version for your release line: 4.0.9, 4.1.3 or 4.2.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2021-31863 being exploited?
There is no known exploitation of CVE-2021-31863 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-redmine-2021-31863, DEBIAN-CVE-2021-31863, GHSA-8hvw-4p82-cf4x, UBUNTU-CVE-2021-31863.