# CVE-2021-31927: Missing authorization in n/a

> Authenticated attackers can modify any user account across environments due to insecure direct object references in the loyalty platform.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3r8c-rqqr-c7h4

## What is CVE-2021-31927?

CVE-2021-31927 is a medium-severity missing authorization vulnerability in n/a, published on 10 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An Insecure Direct Object Reference (IDOR) vulnerability in Annex Cloud Loyalty Experience Platform <2021.1.0.1 allows any authenticated attacker to modify any existing user, including users assigned to different environments and clients. It was fixed in v2021.1.0.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2021-31927?

It affects 1 product.


Products: Annexcloud Loyalty Experience Platform.

## How do I fix CVE-2021-31927?

No fix has been published for CVE-2021-31927 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-31927 being exploited?

There is no known exploitation of CVE-2021-31927 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-31928](https://insights.sbomify.com/CVE-2021-31928/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-31929](https://insights.sbomify.com/CVE-2021-31929/): Missing authorization in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-31927 and fix it if it is affected.

What it is: CVE-2021-31927 is a medium-severity missing authorization vulnerability in n/a, published on 10 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-31927 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-31927/ (Markdown: https://insights.sbomify.com/CVE-2021-31927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-31927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-31927
- OSV: https://osv.dev/vulnerability/CVE-2021-31927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-31927/
Summaries are generated and may contain mistakes; the official description above is the record.
