{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-31998 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2021-31998 is a medium-severity vulnerability in SUSE Linux Enterprise Server 11-SP3, published on 10 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-31998 and fix it if it is affected.\n\nWhat it is: CVE-2021-31998 is a medium-severity vulnerability in SUSE Linux Enterprise Server 11-SP3, published on 10 Jun 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-31998 in the wild and no public exploit code.\n\nAffected product: SUSE Linux Enterprise Server 11-SP3. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-31998/ (Markdown: https://insights.sbomify.com/CVE-2021-31998/index.md)","id":"CVE-2021-31998","markdown":"https://insights.sbomify.com/CVE-2021-31998/index.md","name":"CVE-2021-31998","record":{"aliases":["GHSA-rqpg-j7j6-g58g","SUSE-SU-2021:14750-1","UBUNTU-CVE-2021-31998","openSUSE-SU-2021:0830-1","openSUSE-SU-2021:0845-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"SUSE Linux package","requires_auth":"none","summary":"Local attackers can escalate privileges to root due to incorrect default permissions in the inn package's post-installation script.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"inn","vendor":"opensuse"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.","ecosystems":["SUSE:Linux Enterprise Point of Sale 11 SP3","SUSE:Linux Enterprise Server 11 SP4-LTSS","SUSE:Package Hub 15 SP2","openSUSE:Leap 15.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"inn: %post calls user owned file allowing local privilege escalation to root","id":"CVE-2021-31998","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2021"},"n_packages":4,"n_references":1,"next":{"headline":"Rancher: Privilege escalation vulnerability via malicious Connection header","id":"CVE-2021-31999"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Point of Sale 11 SP3","fixed":["2.4.2-170.21.3.6.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/suse/inn\u0026distro=SUSE%20Linux%20Enterprise%20Point%20of%20Sale%2011%20SP3","source":"SUSE-SU-2021:14750-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4-LTSS","fixed":["2.4.2-170.21.3.6.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/suse/inn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4-LTSS","source":"SUSE-SU-2021:14750-1"},{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["2.6.2-bp152.2.8.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/suse/inn\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2021:0845-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["2.6.2-lp152.2.6.1"],"introduced":["0"],"last_affected":[],"package":"inn","purl":"pkg:rpm/opensuse/inn\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:0830-1"}],"prev":{"headline":"Privilege escalation in Factory","id":"CVE-2021-31997"},"products":["SUSE Linux Enterprise Server 11-SP3","openSUSE Backports SLE-15-SP2","openSUSE Leap 15.2"],"published":"2021-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["SUSE","openSUSE"]},"summary":"Local attackers can escalate privileges to root due to incorrect default permissions in the inn package's post-installation script.","url":"https://insights.sbomify.com/CVE-2021-31998/"}