CVE-2021-31999 Rancher: Privilege escalation vulnerability via malicious Connection header

High 8.8 Published Updated

Attackers can escalate privileges by forging impersonation headers, allowing them to act as other users within the cluster.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-31999?

CVE-2021-31999 is a high-severity vulnerability in Rancher, published on 15 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Reliance on Untrusted Inputs in a Security Decision vulnerability in Rancher allows users in the cluster to act as others users in the cluster by forging the "Impersonate-User" or "Impersonate-Group" headers. This issue affects: Rancher versions prior to 2.5.9. Rancher versions prior to 2.4.16.

Weakness: CWE-807

Which versions are affected by CVE-2021-31999?

5 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.

PackageAffectedFixed in
github.com/rancher/rancher GoFrom 2.0.02.4.16
github.com/rancher/rancher GoFrom 2.0.02.4.16
github.com/rancher/rancher GoFrom 2.0.0+incompatibleNone
github.com/rancher/rancher GoFrom 2.5.02.5.9
github.com/rancher/rancher GoFrom 2.5.02.5.9

Products include Rancher Rancher.

How do I fix CVE-2021-31999?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.4.16 or 2.5.9.

Is CVE-2021-31999 being exploited?

There is no known exploitation of CVE-2021-31999 in the wild and no public exploit code.

Sources

Also known as GHSA-pvxj-25m6-7vqr, GO-2024-2778.

Is CVE-2021-31999 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free