# CVE-2021-32036: Denial of Service and Data Integrity vulnerability in features command

> An authenticated user can cause denial of service and potential data integrity issues by repeatedly invoking the features command.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 19 Nov 2024
- **Also known as:** BIT-mongodb-2021-32036, CLSA-2022-1645465490, GHSA-4wcp-phx2-2w2x, UBUNTU-CVE-2021-32036

## What is CVE-2021-32036?

CVE-2021-32036 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authenticated user without any specific authorizations may be able to repeatedly invoke the features command where at a high volume may lead to resource depletion or generate high lock contention. This may result in denial of service and in rare cases could result in id field collisions. This issue affects MongoDB Server v5.0 versions prior to and including 5.0.3; MongoDB Server v4.4 versions prior to and including 4.4.9; MongoDB Server v4.2 versions prior to and including 4.2.16 and MongoDB Server v4.0 versions prior to and including 4.0.28

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2021-32036?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 2.0.0 | 4.2.18, 4.4.10, 5.0.4 |

Products: Mongodb Mongodb.

## How do I fix CVE-2021-32036?

Upgrade mongodb to a fixed version for your release line: 4.2.18, 4.4.10 or 5.0.4.

## Is CVE-2021-32036 being exploited?

There is no known exploitation of CVE-2021-32036 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32036 and fix it if it is affected.

What it is: CVE-2021-32036 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32036 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 2.0.0; fixed in 4.2.18, 4.4.10, 5.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32036/ (Markdown: https://insights.sbomify.com/CVE-2021-32036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32036
- OSV: https://osv.dev/vulnerability/CVE-2021-32036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32036/
Summaries are generated and may contain mistakes; the official description above is the record.
