# CVE-2021-32040: Large aggregation pipelines with a specific stage can crash mongod under default configuration

> An attacker can crash the MongoDB server by submitting a specially crafted, extremely long aggregation pipeline, causing a stack overflow.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-mongodb-2021-32040, GHSA-hmq6-2xj3-79w5, UBUNTU-CVE-2021-32040

## What is CVE-2021-32040?

CVE-2021-32040 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 12 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

It may be possible to have an extremely long aggregation pipeline in conjunction with a specific stage/operator and cause a stack overflow due to the size of the stack frames used by that stage. If an attacker could cause such an aggregation to occur, they could maliciously crash MongoDB in a DoS attack. This vulnerability affects MongoDB Server v4.4 versions prior to and including 4.4.28, MongoDB Server v5.0 versions prior to 5.0.4 and MongoDB Server v4.2 versions prior to 4.2.16.

Workaround: >= v4.2.16 users and all v4.4 users can add the --setParameter internalPipelineLengthLimit=50 instead of the default 1000 to mongod at startup to prevent a crash.

Weakness: CWE-787 (Out-of-bounds Write), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2021-32040?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 4.2.0 | 4.2.16, 4.4.11, 5.0.4 |

Products: Mongodb Mongodb.

## How do I fix CVE-2021-32040?

Upgrade mongodb to a fixed version for your release line: 4.2.16, 4.4.11 or 5.0.4.

## Is CVE-2021-32040 being exploited?

There is no known exploitation of CVE-2021-32040 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32040 and fix it if it is affected.

What it is: CVE-2021-32040 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 12 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32040 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 4.2.0; fixed in 4.2.16, 4.4.11, 5.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32040/ (Markdown: https://insights.sbomify.com/CVE-2021-32040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32040
- OSV: https://osv.dev/vulnerability/CVE-2021-32040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32040/
Summaries are generated and may contain mistakes; the official description above is the record.
