# CVE-2021-32050: MongoDB Driver may publish events containing authentication-related data

> MongoDB drivers may leak authentication data to application logs if the command listener feature is enabled, exposing sensitive credentials.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Aug 2023
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2021-32050, GHSA-vxvm-qww3-2fh7, JLSEC-2026-178, MINI-xmcp-g5p7-ffr7, UBUNTU-CVE-2021-32050

## What is CVE-2021-32050?

CVE-2021-32050 is a medium-severity vulnerability in MongoDB C Driver, published on 29 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Some MongoDB Drivers may erroneously publish events containing authentication-related data to a command listener configured by an application. The published events may contain security-sensitive data when specific authentication-related commands are executed.

Without due care, an application may inadvertently expose this sensitive information, e.g., by writing it to a log file. This issue only arises if an application enables the command listener feature (this is not enabled by default).

This issue affects the MongoDB C Driver 1.0.0 prior to 1.17.7, MongoDB PHP Driver 1.0.0 prior to 1.9.2, MongoDB Swift Driver 1.0.0 prior to 1.1.1, MongoDB Node.js Driver 3.6 prior to 3.6.10, MongoDB Node.js Driver 4.0 prior to 4.17.0 and MongoDB Node.js Driver 5.0 prior to 5.8.0. This issue also affects users of the MongoDB C++ Driver dependent on the C driver 1.0.0 prior to 1.17.7 (C++ driver prior to 3.7.0).

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32050?

10 open source packages ship an affected version, including github.com/mongodb/mongo-swift-driver, mongodb/mongodb and mongodb. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mongodb/mongo-swift-driver` | SwiftURL | From 1.0.0 | 1.1.1 |
| `github.com/mongodb/mongo-swift-driver` | SwiftURL | From 1.0.0 | 1.1.1 |
| `mongodb/mongodb` | Packagist | From 1.0.0 | 1.9.2 |
| `mongodb/mongodb` | Packagist | From 1.0.0 | 1.9.2 |
| `mongodb` | npm | From 3.6.0 | 3.6.10 |
| `mongodb` | npm | From 3.6.0 | 3.6.10 |
| `mongodb` | npm | From 4.0.0 | 4.17.0 |
| `mongodb` | npm | From 4.0.0 | 4.17.0 |
| `mongodb` | npm | From 5.0.0 | 5.8.0 |
| `mongodb` | npm | From 5.0.0 | 5.8.0 |

Products: Mongodb C\+\+, Mongodb C Driver, Mongodb Node.js, Mongodb Php Driver, Mongodb Swift Driver.

## How do I fix CVE-2021-32050?

Upgrade github.com/mongodb/mongo-swift-driver to 1.1.1 or later.

## Is CVE-2021-32050 being exploited?

There is no known exploitation of CVE-2021-32050 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32050 and fix it if it is affected.

What it is: CVE-2021-32050 is a medium-severity vulnerability in MongoDB C Driver, published on 29 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32050 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mongodb/mongo-swift-driver (SwiftURL): affected from 1.0.0; fixed in 1.1.1
- github.com/mongodb/mongo-swift-driver (SwiftURL): affected from 1.0.0; fixed in 1.1.1
- mongodb/mongodb (Packagist): affected from 1.0.0; fixed in 1.9.2
- mongodb/mongodb (Packagist): affected from 1.0.0; fixed in 1.9.2
- mongodb (npm): affected from 3.6.0; fixed in 3.6.10
- mongodb (npm): affected from 3.6.0; fixed in 3.6.10
- mongodb (npm): affected from 4.0.0; fixed in 4.17.0
- mongodb (npm): affected from 4.0.0; fixed in 4.17.0
- mongodb (npm): affected from 5.0.0; fixed in 5.8.0
- mongodb (npm): affected from 5.0.0; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32050/ (Markdown: https://insights.sbomify.com/CVE-2021-32050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32050
- OSV: https://osv.dev/vulnerability/CVE-2021-32050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32050/
Summaries are generated and may contain mistakes; the official description above is the record.
