# CVE-2021-32052: Header injection possible in Django

> Header injection possible in Django applications using URLValidator with newlines in HTTP responses, requiring specific application logic to exploit.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-django-2021-32052, DEBIAN-CVE-2021-32052, GHSA-qm57-vhq3-3fwf, PYSEC-2021-8, UBUNTU-CVE-2021-32052

## What is CVE-2021-32052?

CVE-2021-32052 is a medium-severity vulnerability in Djangoproject Django, published on 6 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Django 2.2 before 2.2.22, 3.1 before 3.1.10, and 3.2 before 3.2.2 (with Python 3.9.5+), URLValidator does not prohibit newlines and tabs (unless the URLField form field is used). If an application uses values with newlines in an HTTP response, header injection can occur. Django itself is unaffected because HttpResponse prohibits newlines in HTTP headers.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-32052?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 2.2.0 | 2.2.22, 3.1.10, 3.2.2 |
| `django` | PyPI | From 2.2 | 2.2.22, 3.1.10, 3.2.2 |
| `django` | PyPI | From 2.2 | 2.2.22 |
| `django` | PyPI | From 3.1 | 3.1.10 |
| `django` | PyPI | From 3.2 | 3.2.2 |
| `Django` | PyPI | From 2.2 | 2.2.22 |
| `Django` | PyPI | From 3.1 | 3.1.10 |
| `Django` | PyPI | From 3.2 | 3.2.2 |

Products: Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2021-32052?

Upgrade django to a fixed version for your release line: 2.2.22, 3.1.10 or 3.2.2.

## Is CVE-2021-32052 being exploited?

There is no known exploitation of CVE-2021-32052 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32052 and fix it if it is affected.

What it is: CVE-2021-32052 is a medium-severity vulnerability in Djangoproject Django, published on 6 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32052 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 2.2.0; fixed in 2.2.22, 3.1.10, 3.2.2
- django (PyPI): affected from 2.2; fixed in 2.2.22, 3.1.10, 3.2.2
- django (PyPI): affected from 2.2; fixed in 2.2.22
- django (PyPI): affected from 3.1; fixed in 3.1.10
- django (PyPI): affected from 3.2; fixed in 3.2.2
- Django (PyPI): affected from 2.2; fixed in 2.2.22
- Django (PyPI): affected from 3.1; fixed in 3.1.10
- Django (PyPI): affected from 3.2; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32052/ (Markdown: https://insights.sbomify.com/CVE-2021-32052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32052
- OSV: https://osv.dev/vulnerability/CVE-2021-32052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32052/
Summaries are generated and may contain mistakes; the official description above is the record.
