# CVE-2021-32053: Uncontrolled Resource Consumption in JPA Server in HAPI FHIR

> Attackers can cause denial of service in HAPI FHIR JPA Server by triggering resource-intensive history requests that force full index scans.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-67f6-c8mx-4q2m

## What is CVE-2021-32053?

CVE-2021-32053 is a medium-severity denial of service vulnerability in n/a, published on 10 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JPA Server in HAPI FHIR before 5.4.0 allows a user to deny service (e.g., disable access to the database after the attack stops) via history requests. This occurs because of a SELECT COUNT statement that requires a full index scan, with an accompanying large amount of server resources if there are many simultaneous history requests.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-32053?

2 open source packages ship an affected version, including ca.uhn.hapi.fhir:hapi-fhir-jpaserver-base. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:hapi-fhir-jpaserver-base` | Maven | All versions | 5.4.0 |
| `ca.uhn.hapi.fhir:hapi-fhir-jpaserver-base` | Maven | All versions | 5.4.0 |

Products: Fhir Hapi Fhir.

## How do I fix CVE-2021-32053?

Upgrade ca.uhn.hapi.fhir:hapi-fhir-jpaserver-base to 5.4.0 or later.

## Is CVE-2021-32053 being exploited?

There is no known exploitation of CVE-2021-32053 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-12741](https://insights.sbomify.com/CVE-2019-12741/): Cross-site Scripting in HAPI FHIR (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32053 and fix it if it is affected.

What it is: CVE-2021-32053 is a medium-severity denial of service vulnerability in n/a, published on 10 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32053 in the wild and no public exploit code.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:hapi-fhir-jpaserver-base (Maven): affected all versions; fixed in 5.4.0
- ca.uhn.hapi.fhir:hapi-fhir-jpaserver-base (Maven): affected all versions; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32053/ (Markdown: https://insights.sbomify.com/CVE-2021-32053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32053
- OSV: https://osv.dev/vulnerability/CVE-2021-32053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32053/
Summaries are generated and may contain mistakes; the official description above is the record.
