# CVE-2021-32061: S3Scanner allows Directory Traversal

> An attacker can exploit a crafted bucket response to perform directory traversal, potentially reading unauthorized files from the system.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qppg-v75c-r5ff, PYSEC-2021-433

## What is CVE-2021-32061?

CVE-2021-32061 is a medium-severity path traversal vulnerability in n/a, published on 29 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

S3Scanner before 2.0.2 allows Directory Traversal via a crafted bucket, as demonstrated by a <Key>../ substring in a ListBucketResult element.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-32061?

3 open source packages ship an affected version, including s3scanner. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `s3scanner` | PyPI | All versions | 2.0.2 |
| `s3scanner` | PyPI | All versions | 2.0.2 |
| `s3scanner` | PyPI | All versions | 2.0.2 |

Products: S3scanner Project S3scanner.

## How do I fix CVE-2021-32061?

Upgrade s3scanner to 2.0.2 or later.

## Is CVE-2021-32061 being exploited?

There is no known exploitation of CVE-2021-32061 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32061 and fix it if it is affected.

What it is: CVE-2021-32061 is a medium-severity path traversal vulnerability in n/a, published on 29 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32061 in the wild and no public exploit code.

Affected packages and fixed versions:
- s3scanner (PyPI): affected all versions; fixed in 2.0.2
- s3scanner (PyPI): affected all versions; fixed in 2.0.2
- s3scanner (PyPI): affected all versions; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32061/ (Markdown: https://insights.sbomify.com/CVE-2021-32061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32061
- OSV: https://osv.dev/vulnerability/CVE-2021-32061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32061/
Summaries are generated and may contain mistakes; the official description above is the record.
