# CVE-2021-32091: Cross-site scripting in LocalStack

> An XSS vulnerability in LocalStack allows attackers to execute arbitrary scripts in the context of the application.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-37m5-42qp-4qpr, PYSEC-2021-102

## What is CVE-2021-32091?

CVE-2021-32091 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross-site scripting (XSS) vulnerability exists in StackLift LocalStack 0.12.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-32091?

3 open source packages ship an affected version, including localstack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `localstack` | PyPI | All versions to 0.12.10 | None |
| `localstack` | PyPI | All versions to 0.12.10 | None |
| `localstack` | PyPI | All versions | 0.12.6.1 |

Products: Localstack Localstack.

## How do I fix CVE-2021-32091?

Upgrade localstack to 0.12.6.1 or later.

## Is CVE-2021-32091 being exploited?

There is no known exploitation of CVE-2021-32091 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-32090](https://insights.sbomify.com/CVE-2021-32090/): Command injection in LocalStack (critical 9.8)
- [CVE-2023-48054](https://insights.sbomify.com/CVE-2023-48054/): Missing SSL certificate validation in localstack (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32091 and fix it if it is affected.

What it is: CVE-2021-32091 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32091 in the wild and no public exploit code.

Affected packages and fixed versions:
- localstack (PyPI): affected all versions up to 0.12.10; no fix listed
- localstack (PyPI): affected all versions up to 0.12.10; no fix listed
- localstack (PyPI): affected all versions; fixed in 0.12.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32091/ (Markdown: https://insights.sbomify.com/CVE-2021-32091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32091
- OSV: https://osv.dev/vulnerability/CVE-2021-32091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32091/
Summaries are generated and may contain mistakes; the official description above is the record.
