{"answers":{"affected":"2 open source packages ship an affected version, including icecoder/icecoder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32106 in the wild and no public exploit code.","fix":"Upgrade icecoder/icecoder to 8.1 or later.","what":"CVE-2021-32106 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Jun 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32106 and fix it if it is affected.\n\nWhat it is: CVE-2021-32106 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Jun 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-32106 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- icecoder/icecoder (Packagist): affected all versions; fixed in 8.1\n- icecoder/icecoder (Packagist): affected all versions; fixed in 8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32106/ (Markdown: https://insights.sbomify.com/CVE-2021-32106/index.md)","id":"CVE-2021-32106","markdown":"https://insights.sbomify.com/CVE-2021-32106/index.md","name":"CVE-2021-32106","record":{"aliases":["GHSA-jf9v-q8vh-3fmc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ICEcoder code editor","requires_auth":"low_privilege","summary":"Reflected XSS in ICEcoder allows attackers to execute arbitrary JavaScript via the replace parameter, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"icecoder","vendor":"icecoder"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In ICEcoder 8.0 allows, a reflected XSS vulnerability was identified in the multipe-results.php page due to insufficient sanitization of the _GET['replace'] variable. As a result, arbitrary Javascript code can get executed.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in ICEcoder","id":"CVE-2021-32106","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2021-32122"},"packages":[{"ecosystem":"Packagist","fixed":["8.1"],"introduced":["0"],"last_affected":[],"package":"icecoder/icecoder","purl":null,"source":"GHSA-jf9v-q8vh-3fmc"},{"ecosystem":"Packagist","fixed":["8.1"],"introduced":["0"],"last_affected":[],"package":"icecoder/icecoder","purl":"pkg:composer/icecoder/icecoder","source":"GHSA-jf9v-q8vh-3fmc"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2021-32104"},"products":["n/a"],"published":"2021-06-08","related":[{"cvss_score":7.5,"headline":"ICEcoder vulnerable to Path Traversal","id":"CVE-2022-34026","kev_date_added":null,"published":"2022-09-22"},{"cvss_score":6.3,"headline":"ICEcoder Path Traversal vulnerability","id":"CVE-2024-41373","kev_date_added":null,"published":"2024-07-26"},{"cvss_score":6.1,"headline":"ICEcoder vulnerable to Cross Site Scripting","id":"CVE-2024-41374","kev_date_added":null,"published":"2024-07-26"},{"cvss_score":6.1,"headline":"ICEcoder vulnerable to Cross Site Scripting","id":"CVE-2024-41375","kev_date_added":null,"published":"2024-07-26"},{"cvss_score":5.4,"headline":"Cross-site Scripting (XSS) - Reflected in icecoder/icecoder","id":"CVE-2021-3862","kev_date_added":null,"published":"2022-01-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Reflected XSS in ICEcoder allows attackers to execute arbitrary JavaScript via the replace parameter, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2021-32106/"}