CVE-2021-32297 LIEF heap-buffer-overflow
A heap-buffer-overflow in the LIEF library allows attackers to execute arbitrary code via crafted PE files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32297?
CVE-2021-32297 is a high-severity memory corruption vulnerability in n/a, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.
Weakness: CWE-787
Which versions are affected by CVE-2021-32297?
3 open source packages ship an affected version, including lief. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
lief PyPI | All versions | 0.11.0 |
lief PyPI | All versions | 0.11.0 |
lief PyPI | All versions | 0.11.5 |
Products include Lief-Project Lief.
How do I fix CVE-2021-32297?
Upgrade lief to a fixed version for your release line: 0.11.0 or 0.11.5.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2021-32297 being exploited?
There is no known exploitation of CVE-2021-32297 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2022-38306 LIEF vulnerable to heap based buffer overflow
- CVE-2022-38495 LIEF vulnerable to heap based buffer overflow via print_binary function
- CVE-2022-43171 LIEF heap buffer overflow in the LIEF::MachO::BinaryParser::parse_dyldinfo_generic_bind
- CVE-2022-40922 LIEF vulnerable to denial of service through segmentation fault
- CVE-2022-40923 LIEF vulnerable to denial of service through segmentation fault
Sources
Also known as GHSA-22x7-vwh9-5w4g, PYSEC-2021-324, UBUNTU-CVE-2021-32297.