{"answers":{"affected":"3 open source packages ship an affected version, including lief. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32297 in the wild and no public exploit code.","fix":"Upgrade lief to a fixed version for your release line: 0.11.0 or 0.11.5.","what":"CVE-2021-32297 is a high-severity memory corruption vulnerability in n/a, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32297 and fix it if it is affected.\n\nWhat it is: CVE-2021-32297 is a high-severity memory corruption vulnerability in n/a, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-32297 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lief (PyPI): affected all versions; fixed in 0.11.0\n- lief (PyPI): affected all versions; fixed in 0.11.0\n- lief (PyPI): affected all versions; fixed in 0.11.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32297/ (Markdown: https://insights.sbomify.com/CVE-2021-32297/index.md)","id":"CVE-2021-32297","markdown":"https://insights.sbomify.com/CVE-2021-32297/index.md","name":"CVE-2021-32297","record":{"aliases":["GHSA-22x7-vwh9-5w4g","PYSEC-2021-324","UBUNTU-CVE-2021-32297"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LIEF binary parsing library","requires_auth":"none","summary":"A heap-buffer-overflow in the LIEF library allows attackers to execute arbitrary code via crafted PE files.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"lief","vendor":"lief-project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LIEF heap-buffer-overflow","id":"CVE-2021-32297","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2021-32298"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"lief","purl":null,"source":"GHSA-22x7-vwh9-5w4g"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"lief","purl":"pkg:pypi/lief","source":"GHSA-22x7-vwh9-5w4g"},{"ecosystem":"PyPI","fixed":["0.11.5"],"introduced":["0"],"last_affected":[],"package":"lief","purl":"pkg:pypi/lief","source":"PYSEC-2021-324"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2021-32294"},"products":["n/a"],"published":"2021-09-20","related":[{"cvss_score":7.8,"headline":"LIEF vulnerable to heap based buffer overflow","id":"CVE-2022-38306","kev_date_added":null,"published":"2022-09-13"},{"cvss_score":7.8,"headline":"LIEF vulnerable to heap based buffer overflow via print_binary function","id":"CVE-2022-38495","kev_date_added":null,"published":"2022-09-13"},{"cvss_score":6.5,"headline":"LIEF heap buffer overflow in the LIEF::MachO::BinaryParser::parse_dyldinfo_generic_bind","id":"CVE-2022-43171","kev_date_added":null,"published":"2022-11-17"},{"cvss_score":6.5,"headline":"LIEF vulnerable to denial of service through segmentation fault","id":"CVE-2022-40922","kev_date_added":null,"published":"2022-10-03"},{"cvss_score":6.5,"headline":"LIEF vulnerable to denial of service through segmentation fault","id":"CVE-2022-40923","kev_date_added":null,"published":"2022-09-30"},{"cvss_score":5.5,"headline":"LIEF contains segmentation violation","id":"CVE-2022-38307","kev_date_added":null,"published":"2022-09-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A heap-buffer-overflow in the LIEF library allows attackers to execute arbitrary code via crafted PE files.","url":"https://insights.sbomify.com/CVE-2021-32297/"}