CVE-2021-32472 Moodle Exposure of Sensitive Information to an Unauthorized Actor
Teachers can export forum data from all courses instead of just their own, leading to unauthorized data disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32472?
CVE-2021-32472 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Teachers exporting a forum in CSV format could receive a CSV of forums from all courses in some circumstances. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6 and 3.8 to 3.8.8 are affected.
Weakness: CWE-862
Which versions are affected by CVE-2021-32472?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10.0 | 3.10.4 |
moodle/moodle Packagist | From 3.10.0 | 3.10.4 |
moodle/moodle Packagist | From 3.8.0 | 3.8.9 |
moodle/moodle Packagist | From 3.8.0 | 3.8.9 |
moodle/moodle Packagist | From 3.9.0 | 3.9.7 |
moodle/moodle Packagist | From 3.9.0 | 3.9.7 |
1 more packages
moodle Bitnami | From 3.8.0 | 3.8.9, 3.9.7, 3.10.4 |
Products include Moodle Moodle.
How do I fix CVE-2021-32472?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.8.9 or 3.9.7.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-32472 being exploited?
There is no known exploitation of CVE-2021-32472 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-32472, GHSA-454r-jccq-96q8, UBUNTU-CVE-2021-32472.