# CVE-2021-32473: Moodle Information Disclosure vulnerability

> Students can view unreleased quiz grades via a web service, exposing sensitive academic data prematurely.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-moodle-2021-32473, GHSA-wx87-h539-4775, UBUNTU-CVE-2021-32473

## What is CVE-2021-32473?

CVE-2021-32473 is a medium-severity vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It was possible for a student to view their quiz grade before it had been released, using a quiz web service. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32473?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.10 | 3.10.4 |
| `moodle/moodle` | Packagist | From 3.10 | 3.10.4 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.18 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.18 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.9 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.9 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.7 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.7 |
| `moodle` | Bitnami | All versions | 3.5.18, 3.8.9, 3.9.7, 3.10.4 |

Products: Moodle Moodle.

## How do I fix CVE-2021-32473?

Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.5.18, 3.8.9 or 3.9.7.

## Is CVE-2021-32473 being exploited?

There is no known exploitation of CVE-2021-32473 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32473 and fix it if it is affected.

What it is: CVE-2021-32473 is a medium-severity vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32473 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.4
- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.4
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.18
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.18
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.9
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.9
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.7
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.7
- moodle (Bitnami): affected all versions; fixed in 3.5.18, 3.8.9, 3.9.7, 3.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32473/ (Markdown: https://insights.sbomify.com/CVE-2021-32473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32473
- OSV: https://osv.dev/vulnerability/CVE-2021-32473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32473/
Summaries are generated and may contain mistakes; the official description above is the record.
