CVE-2021-32474 Moodle Blind SQL injection possible via MNet authentication
SQL injection in Moodle allows attackers with admin access or keypair access to manipulate database queries via XML-RPC when MNet is enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32474?
CVE-2021-32474 is a high-severity SQL injection vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Weakness: CWE-89
Which versions are affected by CVE-2021-32474?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.5 | 3.5.18 |
moodle/moodle Packagist | From 3.5 | 3.5.18 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.7 |
moodle/moodle Packagist | From 3.9 | 3.9.7 |
moodle Bitnami | All versions | 3.5.18, 3.8.9, 3.9.7, 3.10.4 |
Products include Moodle Moodle.
How do I fix CVE-2021-32474?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.5.18, 3.8.9 or 3.9.7.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2021-32474 being exploited?
There is no known exploitation of CVE-2021-32474 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-32474, GHSA-rvmc-8gmg-ggqr, UBUNTU-CVE-2021-32474.