# CVE-2021-32474: Moodle Blind SQL injection possible via MNet authentication

> SQL injection in Moodle allows attackers with admin access or keypair access to manipulate database queries via XML-RPC when MNet is enabled.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-moodle-2021-32474, GHSA-rvmc-8gmg-ggqr, UBUNTU-CVE-2021-32474

## What is CVE-2021-32474?

CVE-2021-32474 is a high-severity SQL injection vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2021-32474?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.10 | 3.10.4 |
| `moodle/moodle` | Packagist | From 3.10 | 3.10.4 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.18 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.18 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.9 |
| `moodle/moodle` | Packagist | From 3.8 | 3.8.9 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.7 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.7 |
| `moodle` | Bitnami | All versions | 3.5.18, 3.8.9, 3.9.7, 3.10.4 |

Products: Moodle Moodle.

## How do I fix CVE-2021-32474?

Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.5.18, 3.8.9 or 3.9.7.

## Is CVE-2021-32474 being exploited?

There is no known exploitation of CVE-2021-32474 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32474 and fix it if it is affected.

What it is: CVE-2021-32474 is a high-severity SQL injection vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32474 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.4
- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.4
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.18
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.18
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.9
- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.9
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.7
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.7
- moodle (Bitnami): affected all versions; fixed in 3.5.18, 3.8.9, 3.9.7, 3.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32474/ (Markdown: https://insights.sbomify.com/CVE-2021-32474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32474
- OSV: https://osv.dev/vulnerability/CVE-2021-32474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32474/
Summaries are generated and may contain mistakes; the official description above is the record.
