CVE-2021-32475 Moodle stored Cross-site Scripting
Stored XSS in Moodle quiz grading reports allows attackers to inject scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32475?
CVE-2021-32475 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 11 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Which versions are affected by CVE-2021-32475?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.5 | 3.5.18 |
moodle/moodle Packagist | From 3.5 | 3.5.18 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.7 |
moodle/moodle Packagist | From 3.9 | 3.9.7 |
moodle Bitnami | All versions | 3.5.18, 3.8.9, 3.9.7, 3.10.4 |
Products include Moodle Moodle.
How do I fix CVE-2021-32475?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.5.18, 3.8.9 or 3.9.7.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-32475 being exploited?
There is no known exploitation of CVE-2021-32475 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-32475, GHSA-5wjh-v7c8-wrhx, UBUNTU-CVE-2021-32475.