CVE-2021-32476 Moodle denial-of-service risk in the draft files area
Attackers can cause denial of service by uploading files exceeding user limits in the draft files area of Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32476?
CVE-2021-32476 is a high-severity denial of service vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Weakness: CWE-770
Which versions are affected by CVE-2021-32476?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.5.17 | 3.5.18 |
moodle/moodle Packagist | From 3.5.17 | 3.5.18 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
3 more packages
moodle/moodle Packagist | From 3.9 | 3.9.7 |
moodle/moodle Packagist | From 3.9 | 3.9.7 |
moodle Bitnami | All versions | 3.5.18, 3.8.9, 3.9.7, 3.10.4 |
Products include Moodle Moodle.
How do I fix CVE-2021-32476?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.5.18, 3.8.9 or 3.9.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-32476 being exploited?
There is no known exploitation of CVE-2021-32476 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-32476, GHSA-4qxc-qxrp-33cw, UBUNTU-CVE-2021-32476.