CVE-2021-32478 Moodle reflected XSS
Attackers can exploit unsanitized redirect URIs in Moodle's LTI endpoint to perform reflected XSS and open redirects, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32478?
CVE-2021-32478 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.
Which versions are affected by CVE-2021-32478?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.10 | 3.10.4 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
moodle/moodle Packagist | From 3.8 | 3.8.9 |
moodle/moodle Packagist | From 3.9 | 3.9.7 |
moodle/moodle Packagist | From 3.9 | 3.9.7 |
1 more packages
moodle Bitnami | All versions | 3.8.9, 3.9.7, 3.10.4 |
Products include Moodle Moodle.
How do I fix CVE-2021-32478?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.8.9 or 3.9.7.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-32478 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32478 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-32478, GHSA-78fm-qhh8-8858, UBUNTU-CVE-2021-32478.