{"answers":{"affected":"7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32478 exists.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.10.4, 3.8.9 or 3.9.7.","what":"CVE-2021-32478 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32478 and fix it if it is affected.\n\nWhat it is: CVE-2021-32478 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32478 exists.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.4\n- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.4\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.9\n- moodle/moodle (Packagist): affected from 3.8; fixed in 3.8.9\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.7\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.7\n- moodle (Bitnami): affected all versions; fixed in 3.8.9, 3.9.7, 3.10.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32478/ (Markdown: https://insights.sbomify.com/CVE-2021-32478/index.md)","id":"CVE-2021-32478","markdown":"https://insights.sbomify.com/CVE-2021-32478/index.md","name":"CVE-2021-32478","record":{"aliases":["BIT-moodle-2021-32478","GHSA-78fm-qhh8-8858","UBUNTU-CVE-2021-32478"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can exploit unsanitized redirect URIs in Moodle's LTI endpoint to perform reflected XSS and open redirects, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-32478.yaml","stars":null,"title":"Moodle 3.8-3.10.3 - Reflected XSS \u0026 Open Redirect"}],"tier":"weaponised"},"has_fix":true,"headline":"Moodle reflected XSS","id":"CVE-2021-32478","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2021"},"n_packages":7,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-32481"},"packages":[{"ecosystem":"Bitnami","fixed":["3.8.9","3.9.7","3.10.4"],"introduced":["0","3.9.0","3.10.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2021-32478"},{"ecosystem":"Packagist","fixed":["3.10.4"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-78fm-qhh8-8858"},{"ecosystem":"Packagist","fixed":["3.10.4"],"introduced":["3.10"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-78fm-qhh8-8858"},{"ecosystem":"Packagist","fixed":["3.8.9"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-78fm-qhh8-8858"},{"ecosystem":"Packagist","fixed":["3.8.9"],"introduced":["3.8"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-78fm-qhh8-8858"},{"ecosystem":"Packagist","fixed":["3.9.7"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-78fm-qhh8-8858"},{"ecosystem":"Packagist","fixed":["3.9.7"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-78fm-qhh8-8858"}],"prev":{"headline":"Moodle Exposure of Sensitive Information to an Unauthorized Actor","id":"CVE-2021-32477"},"products":["moodle"],"published":"2022-03-11","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can exploit unsanitized redirect URIs in Moodle's LTI endpoint to perform reflected XSS and open redirects, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2021-32478/"}