# CVE-2021-32610: Directory Traversal in Archive_Tar

> Attackers can exploit symlink handling in Archive_Tar to read or modify files outside the intended extraction directory.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLEANSTART-2024-PW74857, DEBIAN-CVE-2021-32610, DLA-2721-1, DRUPAL-CORE-2021-004, GHSA-p8q8-jfcv-g2h2, MGASA-2021-0393, SUSE-SU-2022:3198-1, SUSE-SU-2022:3198-2, UBUNTU-CVE-2021-32610, USN-5027-1, USN-5027-2, openSUSE-SU-2024:11168-1, openSUSE-SU-2024:11170-1

## What is CVE-2021-32610?

CVE-2021-32610 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 27 Jul 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Archive_Tar before 1.4.14, symlinks can refer to targets outside of the extracted archive, a different vulnerability than CVE-2020-36193.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2021-32610?

3 open source packages ship an affected version, including pear/archive_tar and drupal/core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pear/archive_tar` | Packagist | All versions | 1.4.14 |
| `pear/archive_tar` | Packagist | All versions | 1.4.14 |
| `drupal/core` | Packagist | From 8.0.0 | 8.9.17, 9.1.11, 9.2.2 |
| `php8-pear` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP4 | All versions | 1.10.21-150400.9.3.1 |
| `php8-pear` | openSUSE:Leap 15.4 | All versions | 1.10.21-150400.9.3.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Php Archive Tar.

## How do I fix CVE-2021-32610?

Upgrade pear/archive_tar to 1.4.14 or later.

## Is CVE-2021-32610 being exploited?

There is no known exploitation of CVE-2021-32610 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32610 and fix it if it is affected.

What it is: CVE-2021-32610 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 27 Jul 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32610 in the wild and no public exploit code.

Affected packages and fixed versions:
- pear/archive_tar (Packagist): affected all versions; fixed in 1.4.14
- pear/archive_tar (Packagist): affected all versions; fixed in 1.4.14
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.9.17, 9.1.11, 9.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32610/ (Markdown: https://insights.sbomify.com/CVE-2021-32610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32610
- OSV: https://osv.dev/vulnerability/CVE-2021-32610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32610/
Summaries are generated and may contain mistakes; the official description above is the record.
