# CVE-2021-32618: Open Redirect Vulnerability

> Attackers can redirect users to malicious sites via crafted next parameters if Werkzeug's default header correction is disabled.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6qmf-fj6m-686c, PYSEC-2021-123, UBUNTU-CVE-2021-32618

## What is CVE-2021-32618?

CVE-2021-32618 is a low-severity vulnerability in Flask-Middleware flask-security, published on 17 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is an independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. All versions of Flask-Security-Too allow redirects after many successful views (e.g. /login) by honoring the ?next query param. There is code in FS to validate that the url specified in the next parameter is either relative OR has the same netloc (network location) as the requesting URL. This check utilizes Pythons urlsplit library. However many browsers are very lenient on the kind of URL they accept and 'fill in the blanks' when presented with a possibly incomplete URL. As a concrete example - setting http://login?next=\\\github.com will pass FS's relative URL check however many browsers will gladly convert this to http://github.com. Thus an attacker could send such a link to an unwitting user, using a legitimate site and have it redirect to whatever site they want. This is considered a low severity due to the fact that if Werkzeug is used (which is very common with Flask applications) as the WSGI layer, it by default ALWAYS ensures that the Location header is absolute - thus making this attack vector mute. It is possible for application writers to modify this default behavior by setting the 'autocorrect_location_header=False`.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-32618?

3 open source packages ship an affected version, including flask-security-too and Flask-Security-Too. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-security-too` | PyPI | All versions | 4.1.0 |
| `flask-security-too` | PyPI | All versions | 4.1.0 |
| `Flask-Security-Too` | PyPI | All versions | 4.1.0 |

Products: Flask-Security Project Flask-Security.

## How do I fix CVE-2021-32618?

Upgrade flask-security-too to 4.1.0 or later.

## Is CVE-2021-32618 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32618 exists.

Public exploit code:

- Python Flask-Security - Open Redirect (nuclei): http/cves/2021/CVE-2021-32618.yaml

## Other vulnerabilities in Flask-Middleware flask-security

- [CVE-2021-23385](https://insights.sbomify.com/CVE-2021-23385/): Open Redirect (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32618 and fix it if it is affected.

What it is: CVE-2021-32618 is a low-severity vulnerability in Flask-Middleware flask-security, published on 17 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32618 exists.

Affected packages and fixed versions:
- flask-security-too (PyPI): affected all versions; fixed in 4.1.0
- flask-security-too (PyPI): affected all versions; fixed in 4.1.0
- Flask-Security-Too (PyPI): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32618/ (Markdown: https://insights.sbomify.com/CVE-2021-32618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32618
- OSV: https://osv.dev/vulnerability/CVE-2021-32618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32618/
Summaries are generated and may contain mistakes; the official description above is the record.
