CVE-2021-32619 Static imports inside dynamically imported modules do not adhere to permission checks
Attackers can bypass network and file system permission checks in Deno by using static imports within dynamically imported modules.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32619?
CVE-2021-32619 is a critical vulnerability in denoland deno, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. In Deno versions 1.5.0 to 1.10.1, modules that are dynamically imported through `import()` or `new Worker` might have been able to bypass network and file system permission checks when statically importing other modules. The vulnerability has been patched in Deno release 1.10.2.
Which versions are affected by CVE-2021-32619?
2 open source packages ship an affected version, including deno. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
deno crates.io | From 1.5.0 | 1.10.2 |
deno crates.io | From 1.5.0 | 1.10.2 |
Products include Deno Deno.
How do I fix CVE-2021-32619?
Upgrade deno to 1.10.2 or later.
Is CVE-2021-32619 being exploited?
There is no known exploitation of CVE-2021-32619 in the wild and no public exploit code.
Other vulnerabilities in denoland deno
- CVE-2023-28445 Deno improperly handles resizable ArrayBuffer
- CVE-2022-24783 Sandbox bypass leading to arbitrary code execution in Deno
- CVE-2026-22863 Deno node:crypto doesn't finalize cipher
- CVE-2024-27936 Deno interactive permission prompt spoofing via improper ANSI stripping
- CVE-2023-28446 Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization
Sources
Also known as GHSA-xpwj-7v8q-mcgj, JLSEC-2026-98.