# CVE-2021-32619: Static imports inside dynamically imported modules do not adhere to permission checks

> Attackers can bypass network and file system permission checks in Deno by using static imports within dynamically imported modules.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xpwj-7v8q-mcgj, JLSEC-2026-98

## What is CVE-2021-32619?

CVE-2021-32619 is a critical vulnerability in denoland deno, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. In Deno versions 1.5.0 to 1.10.1, modules that are dynamically imported through `import()` or `new Worker` might have been able to bypass network and file system permission checks when statically importing other modules. The vulnerability has been patched in Deno release 1.10.2.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2021-32619?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.5.0 | 1.10.2 |
| `deno` | crates.io | From 1.5.0 | 1.10.2 |

Products: Deno Deno.

## How do I fix CVE-2021-32619?

Upgrade deno to 1.10.2 or later.

## Is CVE-2021-32619 being exploited?

There is no known exploitation of CVE-2021-32619 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)
- [CVE-2023-28446](https://insights.sbomify.com/CVE-2023-28446/): Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32619 and fix it if it is affected.

What it is: CVE-2021-32619 is a critical vulnerability in denoland deno, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32619 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.5.0; fixed in 1.10.2
- deno (crates.io): affected from 1.5.0; fixed in 1.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32619/ (Markdown: https://insights.sbomify.com/CVE-2021-32619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32619
- OSV: https://osv.dev/vulnerability/CVE-2021-32619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32619/
Summaries are generated and may contain mistakes; the official description above is the record.
