# CVE-2021-32620: Users registered with email verification can self re-activate their disabled accounts

> Disabled users can reactivate their accounts via registration links in XWiki when email verification is enabled, bypassing administrative deactivation controls.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-76mp-659p-rw65

## What is CVE-2021-32620?

CVE-2021-32620 is a high-severity authentication bypass vulnerability in Xwiki Xwiki, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions prior to 11.10.13, 12.6.7, and 12.10.2, a user disabled on a wiki using email verification for registration canouldre-activate themself by using the activation link provided for his registration. The problem has been patched in the following versions of XWiki: 11.10.13, 12.6.7, 12.10.2, 13.0. It is possible to workaround the issue by resetting the `validkey` property of the disabled XWiki users. This can be done by editing the user profile with object editor.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2021-32620?

6 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.commons:xwiki-commons-core` | Maven | From 11.6 | 11.10.13 |
| `org.xwiki.commons:xwiki-commons-core` | Maven | From 11.6 | 11.10.13 |
| `org.xwiki.commons:xwiki-commons-core` | Maven | From 12.0 | 12.6.7 |
| `org.xwiki.commons:xwiki-commons-core` | Maven | From 12.0 | 12.6.7 |
| `org.xwiki.commons:xwiki-commons-core` | Maven | From 12.10.0 | 12.10.2 |
| `org.xwiki.commons:xwiki-commons-core` | Maven | From 12.10.0 | 12.10.2 |

Products: Xwiki Xwiki.

## How do I fix CVE-2021-32620?

Upgrade org.xwiki.commons:xwiki-commons-core to a fixed version for your release line: 11.10.13, 12.6.7 or 12.10.2.

## Is CVE-2021-32620 being exploited?

There is no known exploitation of CVE-2021-32620 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32620 and fix it if it is affected.

What it is: CVE-2021-32620 is a high-severity authentication bypass vulnerability in Xwiki Xwiki, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32620 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.commons:xwiki-commons-core (Maven): affected from 11.6; fixed in 11.10.13
- org.xwiki.commons:xwiki-commons-core (Maven): affected from 11.6; fixed in 11.10.13
- org.xwiki.commons:xwiki-commons-core (Maven): affected from 12.0; fixed in 12.6.7
- org.xwiki.commons:xwiki-commons-core (Maven): affected from 12.0; fixed in 12.6.7
- org.xwiki.commons:xwiki-commons-core (Maven): affected from 12.10.0; fixed in 12.10.2
- org.xwiki.commons:xwiki-commons-core (Maven): affected from 12.10.0; fixed in 12.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32620/ (Markdown: https://insights.sbomify.com/CVE-2021-32620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32620
- OSV: https://osv.dev/vulnerability/CVE-2021-32620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32620/
Summaries are generated and may contain mistakes; the official description above is the record.
