{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-32625 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-32625 is a high-severity vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32625 and fix it if it is affected.\n\nWhat it is: CVE-2021-32625 is a high-severity vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32625 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32625/ (Markdown: https://insights.sbomify.com/CVE-2021-32625/index.md)","id":"CVE-2021-32625","markdown":"https://insights.sbomify.com/CVE-2021-32625/index.md","name":"CVE-2021-32625","record":{"aliases":["ALPINE-CVE-2021-32625","CLEANSTART-2026-CO90102","DEBIAN-CVE-2021-32625","GHSA-46cp-x4x9-6pfq","SUSE-SU-2021:2294-1","UBUNTU-CVE-2021-32625","openSUSE-SU-2021:0841-1","openSUSE-SU-2021:2294-1"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Redis in-memory store","requires_auth":"low_privilege","summary":"Integer overflow in Redis STRALGO LCS command on 32-bit systems allows heap corruption and potential remote code execution.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"redis","vendor":"redislabs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-680","name":"Integer Overflow to Buffer Overflow"}],"description":"Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis version 6.0 or newer, could be exploited using the STRALGO LCS command to corrupt the heap and potentially result with remote code execution. This is a result of an incomplete fix by CVE-2021-29477. The problem is fixed in version 6.2.4 and 6.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to use ACL configuration to prevent clients from using the STRALGO LCS command. On 64 bit systems which have the fixes of CVE-2021-29477 (6.2.3 or 6.0.13), it is sufficient to make sure that the proto-max-bulk-len config parameter is smaller than 2GB (default is 512MB).","ecosystems":["SUSE:Linux Enterprise Module for Server Applications 15 SP2","SUSE:Linux Enterprise Module for Server Applications 15 SP3","openSUSE:Leap 15.2","openSUSE:Leap 15.3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Redis vulnerability in STRALGO LCS on 32-bit systems","id":"CVE-2021-32625","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"integer_overflow","year":"2021"},"n_packages":4,"n_references":5,"next":{"headline":"Lua scripts can overflow the heap-based Lua stack in Redis","id":"CVE-2021-32626"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP2","fixed":["6.0.14-6.5.1"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:rpm/suse/redis\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP2","source":"SUSE-SU-2021:2294-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP3","fixed":["6.0.14-6.5.1"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:rpm/suse/redis\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP3","source":"SUSE-SU-2021:2294-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["6.0.14-lp152.2.6.1"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:rpm/opensuse/redis\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:0841-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["6.0.14-6.5.1"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:rpm/opensuse/redis\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2021:2294-1"}],"prev":{"headline":"Private Field data leak","id":"CVE-2021-32624"},"products":["redis"],"published":"2021-06-02","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["redis"]},"summary":"Integer overflow in Redis STRALGO LCS command on 32-bit systems allows heap corruption and potential remote code execution.","url":"https://insights.sbomify.com/CVE-2021-32625/"}