# CVE-2021-32625: Redis vulnerability in STRALGO LCS on 32-bit systems

> Integer overflow in Redis STRALGO LCS command on 32-bit systems allows heap corruption and potential remote code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-32625, CLEANSTART-2026-CO90102, DEBIAN-CVE-2021-32625, GHSA-46cp-x4x9-6pfq, SUSE-SU-2021:2294-1, UBUNTU-CVE-2021-32625, openSUSE-SU-2021:0841-1, openSUSE-SU-2021:2294-1

## What is CVE-2021-32625?

CVE-2021-32625 is a high-severity vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis version 6.0 or newer, could be exploited using the STRALGO LCS command to corrupt the heap and potentially result with remote code execution. This is a result of an incomplete fix by CVE-2021-29477. The problem is fixed in version 6.2.4 and 6.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to use ACL configuration to prevent clients from using the STRALGO LCS command. On 64 bit systems which have the fixes of CVE-2021-29477 (6.2.3 or 6.0.13), it is sufficient to make sure that the proto-max-bulk-len config parameter is smaller than 2GB (default is 512MB).

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-680 (Integer Overflow to Buffer Overflow)

## Which versions are affected by CVE-2021-32625?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | SUSE:Linux Enterprise Module for Server Applications 15 SP2 | All versions | 6.0.14-6.5.1 |
| `redis` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 6.0.14-6.5.1 |
| `redis` | openSUSE:Leap 15.2 | All versions | 6.0.14-lp152.2.6.1 |
| `redis` | openSUSE:Leap 15.3 | All versions | 6.0.14-6.5.1 |

Products: Fedoraproject Fedora, Redislabs Redis.

## How do I fix CVE-2021-32625?

Upgrade to a fixed version.

## Is CVE-2021-32625 being exploited?

There is no known exploitation of CVE-2021-32625 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32625 and fix it if it is affected.

What it is: CVE-2021-32625 is a high-severity vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32625 in the wild and no public exploit code.

Affected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32625/ (Markdown: https://insights.sbomify.com/CVE-2021-32625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32625
- OSV: https://osv.dev/vulnerability/CVE-2021-32625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32625/
Summaries are generated and may contain mistakes; the official description above is the record.
