# CVE-2021-32633: Remote Code Execution via traversal in TAL expressions

> Attackers can execute remote code via path traversal in TAL expressions if untrusted users are allowed to edit Zope Page Templates.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5pr9-v234-jw36, GHSA-962m-m8jw-8wrr, PYSEC-2021-88

## What is CVE-2021-32633?

CVE-2021-32633 is a medium-severity path traversal vulnerability in Plone Plone, published on 21 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zope is an open-source web application server. In Zope versions prior to 4.6 and 5.2, users can access untrusted modules indirectly through Python modules that are available for direct use. By default, only users with the Manager role can add or edit Zope Page Templates through the web, but sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk from this vulnerability. The problem has been fixed in Zope 5.2 and 4.6. As a workaround, a site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-32633?

9 open source packages ship an affected version, including zope and Zope. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope` | PyPI | All versions | 4.6, 5.2 |
| `zope` | PyPI | All versions | 4.6 |
| `zope` | PyPI | All versions | 4.6 |
| `zope` | PyPI | From 5.0 | 5.2 |
| `zope` | PyPI | From 5.0 | 5.2 |
| `Zope` | PyPI | All versions | 4.6 |
| `Zope` | PyPI | All versions | 4.6 |
| `Zope` | PyPI | From 5.0 | 5.2 |
| `Zope` | PyPI | From 5.0 | 5.2 |

Products: Plone Plone, Zope Zope.

## How do I fix CVE-2021-32633?

Upgrade zope to a fixed version for your release line: 4.6 or 5.2.

## Is CVE-2021-32633 being exploited?

There is no known exploitation of CVE-2021-32633 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32633 and fix it if it is affected.

What it is: CVE-2021-32633 is a medium-severity path traversal vulnerability in Plone Plone, published on 21 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32633 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope (PyPI): affected all versions; fixed in 4.6, 5.2
- zope (PyPI): affected all versions; fixed in 4.6
- zope (PyPI): affected all versions; fixed in 4.6
- zope (PyPI): affected from 5.0; fixed in 5.2
- zope (PyPI): affected from 5.0; fixed in 5.2
- Zope (PyPI): affected all versions; fixed in 4.6
- Zope (PyPI): affected all versions; fixed in 4.6
- Zope (PyPI): affected from 5.0; fixed in 5.2
- Zope (PyPI): affected from 5.0; fixed in 5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32633/ (Markdown: https://insights.sbomify.com/CVE-2021-32633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32633
- OSV: https://osv.dev/vulnerability/CVE-2021-32633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32633/
Summaries are generated and may contain mistakes; the official description above is the record.
