{"answers":{"affected":"2 open source packages ship an affected version, including github.com/authelia/authelia/v4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32637 in the wild and no public exploit code.","fix":"Upgrade github.com/authelia/authelia/v4 to 4.29.3 or later.","what":"CVE-2021-32637 is a critical authentication bypass vulnerability in authelia, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32637 and fix it if it is affected.\n\nWhat it is: CVE-2021-32637 is a critical authentication bypass vulnerability in authelia, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32637 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/authelia/authelia/v4 (Go): affected from 4.0.0-alpha1; fixed in 4.29.3\n- github.com/authelia/authelia/v4 (Go): affected from 4.0.0-alpha1; fixed in 4.29.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32637/ (Markdown: https://insights.sbomify.com/CVE-2021-32637/index.md)","id":"CVE-2021-32637","markdown":"https://insights.sbomify.com/CVE-2021-32637/index.md","name":"CVE-2021-32637","record":{"aliases":["GHSA-68wm-pfjf-wqp6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Single sign-on portal","requires_auth":"none","summary":"Attackers can bypass authentication in Authelia when used with nginx by sending malformed HTTP requests, requiring an upgrade or configuration change.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"authelia","vendor":"authelia"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Authelia is a a single sign-on multi-factor portal for web apps. This affects uses who are using nginx ngx_http_auth_request_module with Authelia, it allows a malicious individual who crafts a malformed HTTP request to bypass the authentication mechanism. It additionally could theoretically affect other proxy servers, but all of the ones we officially support except nginx do not allow malformed URI paths. The problem is rectified entirely in v4.29.3. As this patch is relatively straightforward we can back port this to any version upon request. Alternatively we are supplying a git patch to 4.25.1 which should be relatively straightforward to apply to any version, the git patches for specific versions can be found in the references. The most relevant workaround is upgrading. You can also add a block which fails requests that contains a malformed URI in the internal location block.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication bypassed with malformed request URI","id":"CVE-2021-32637","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"CodeQL runner: Command-line options that make GitHub access tokens visible to other processes are now deprecated","id":"CVE-2021-32638"},"packages":[{"ecosystem":"Go","fixed":["4.29.3"],"introduced":["4.0.0-alpha1"],"last_affected":[],"package":"github.com/authelia/authelia/v4","purl":null,"source":"GHSA-68wm-pfjf-wqp6"},{"ecosystem":"Go","fixed":["4.29.3"],"introduced":["4.0.0-alpha1"],"last_affected":[],"package":"github.com/authelia/authelia/v4","purl":"pkg:golang/github.com/authelia/authelia/v4","source":"GHSA-68wm-pfjf-wqp6"}],"prev":{"headline":"Action Commands (run/shell/exec) Against Library URIs Ignore Configured Remote Endpoint","id":"CVE-2021-32635"},"products":["authelia"],"published":"2021-05-28","related":[{"cvss_score":5.7,"headline":"Authelia allows open redirects on the logout endpoint","id":"CVE-2021-29456","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":0.5,"headline":"Authelia: Improper Neutralization of Input During Web Page Generation Leads to Potential Cross-site Scripting","id":"CVE-2026-33525","kev_date_added":null,"published":"2026-03-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["authelia"]},"summary":"Attackers can bypass authentication in Authelia when used with nginx by sending malformed HTTP requests, requiring an upgrade or configuration change.","url":"https://insights.sbomify.com/CVE-2021-32637/"}