CVE-2021-32641 Reflected XSS when using flashMessages

High 8.1 Published Updated

Attackers can execute arbitrary code via reflected XSS in Auth0 Lock when flashMessage or languageDictionary features process user input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-32641?

CVE-2021-32641 is a high-severity cross-site scripting vulnerability in auth0 lock, published on 4 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

auth0-lock is Auth0's signin solution. Versions of nauth0-lock before and including `11.30.0` are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's `flashMessage` feature is utilized and user input or data from URL parameters is incorporated into the `flashMessage` or the library's `languageDictionary` feature is utilized and user input or data from URL parameters is incorporated into the `languageDictionary`. The vulnerability is patched in version 11.30.1.

Weakness: CWE-79

Which versions are affected by CVE-2021-32641?

2 open source packages ship an affected version, including auth0-lock. It affects 1 product.

PackageAffectedFixed in
auth0-lock npmAll versions11.30.1
auth0-lock npmAll versions11.30.1

Products include Auth0 Lock.

How do I fix CVE-2021-32641?

Upgrade auth0-lock to 11.30.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-32641 being exploited?

There is no known exploitation of CVE-2021-32641 in the wild and no public exploit code.

Sources

Also known as GHSA-jr3j-whm4-9wwm.

Is CVE-2021-32641 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free