{"answers":{"affected":"2 open source packages ship an affected version, including auth0-lock. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-32641 in the wild and no public exploit code.","fix":"Upgrade auth0-lock to 11.30.1 or later.","what":"CVE-2021-32641 is a high-severity cross-site scripting vulnerability in auth0 lock, published on 4 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-32641 and fix it if it is affected.\n\nWhat it is: CVE-2021-32641 is a high-severity cross-site scripting vulnerability in auth0 lock, published on 4 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-32641 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0-lock (npm): affected all versions; fixed in 11.30.1\n- auth0-lock (npm): affected all versions; fixed in 11.30.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32641/ (Markdown: https://insights.sbomify.com/CVE-2021-32641/index.md)","id":"CVE-2021-32641","markdown":"https://insights.sbomify.com/CVE-2021-32641/index.md","name":"CVE-2021-32641","record":{"aliases":["GHSA-jr3j-whm4-9wwm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Auth0 Lock library","requires_auth":"none","summary":"Attackers can execute arbitrary code via reflected XSS in Auth0 Lock when flashMessage or languageDictionary features process user input.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lock","vendor":"auth0"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"auth0-lock is Auth0's signin solution. Versions of nauth0-lock before and including `11.30.0` are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's `flashMessage` feature is utilized and user input or data from URL parameters is incorporated into the `flashMessage` or the library's `languageDictionary` feature is utilized and user input or data from URL parameters is incorporated into the `languageDictionary`. The vulnerability is patched in version 11.30.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected XSS when using flashMessages","id":"CVE-2021-32641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Missing input validation in dynamic discovery example scripts.","id":"CVE-2021-32642"},"packages":[{"ecosystem":"npm","fixed":["11.30.1"],"introduced":["0"],"last_affected":[],"package":"auth0-lock","purl":null,"source":"GHSA-jr3j-whm4-9wwm"},{"ecosystem":"npm","fixed":["11.30.1"],"introduced":["0"],"last_affected":[],"package":"auth0-lock","purl":"pkg:npm/auth0-lock","source":"GHSA-jr3j-whm4-9wwm"}],"prev":{"headline":"ReDoS in Sec-Websocket-Protocol header","id":"CVE-2021-32640"},"products":["lock"],"published":"2021-06-04","related":[{"cvss_score":6.4,"headline":"DOM-based XSS in auth0-lock","id":"CVE-2020-15119","kev_date_added":null,"published":"2020-08-19"},{"cvss_score":6.1,"headline":"HTML injection with additional signup fields","id":"CVE-2022-29172","kev_date_added":null,"published":"2022-05-05"},{"cvss_score":6.1,"headline":"auth0-lock vulnerable to XSS via unsanitized placeholder property","id":"CVE-2019-20174","kev_date_added":null,"published":"2020-02-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["auth0"]},"summary":"Attackers can execute arbitrary code via reflected XSS in Auth0 Lock when flashMessage or languageDictionary features process user input.","url":"https://insights.sbomify.com/CVE-2021-32641/"}