CVE-2021-32650 Arbitrary code execution in october/system
An attacker with backend access can execute arbitrary PHP code via the theme import feature, bypassing safe mode restrictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32650?
CVE-2021-32650 is a high-severity code injection vulnerability in Octobercms October, published on 14 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
October CMS is a self-hosted content management system (CMS) platform based on the Laravel PHP Framework. Prior to versions 1.0.473 and 1.1.6, an attacker with access to the backend is able to execute PHP code by using the theme import feature. This will bypass the safe mode feature that prevents PHP execution in the CMS templates.The issue has been patched in Build 473 (v1.0.473) and v1.1.6. Those unable to upgrade may apply the patch to their installation manually as a workaround.
Which versions are affected by CVE-2021-32650?
4 open source packages ship an affected version, including october/system. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
october/system Packagist | All versions | 1.0.473 |
october/system Packagist | All versions | 1.0.473 |
october/system Packagist | From 1.1.0 | 1.1.6 |
october/system Packagist | From 1.1.0 | 1.1.6 |
Products include Octobercms October.
How do I fix CVE-2021-32650?
Upgrade october/system to a fixed version for your release line: 1.0.473 or 1.1.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2021-32650 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32650 exists.
Other vulnerabilities in Octobercms October
Sources
Also known as GHSA-5hfj-r725-wpc4.