CVE-2021-32668 Cross-Site Scripting in Query Generator & Query View
An attacker with admin privileges can inject malicious scripts via unencoded error messages in Query Generator and View, potentially compromising the backend.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-32668?
CVE-2021-32668 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 20 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When error messages are not properly encoded, the components _QueryGenerator_ and _QueryView_ are vulnerable to both reflected and persistent cross-site scripting. A valid backend user account having administrator privileges is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.
Weakness: CWE-79
Which versions are affected by CVE-2021-32668?
15 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.18 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.18 |
typo3/cms-core Packagist | From 11.0.0 | 11.3.1 |
typo3/cms-core Packagist | From 11.0.0 | 11.3.1 |
typo3/cms-core Packagist | From 8.0.0 | 8.7.41 |
typo3/cms-core Packagist | From 8.0.0 | 8.7.41 |
9 more packages
typo3/cms-core Packagist | From 9.0.0 | 9.5.28 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.28 |
typo3 Bitnami | From 8.0.0 | 8.7.40, 9.5.28, 10.4.17, 11.3.0 |
typo3/cms Packagist | From 10.0.0 | 10.4.18 |
typo3/cms Packagist | From 10.0.0 | 10.4.18 |
typo3/cms Packagist | From 11.0.0 | 11.3.1 |
typo3/cms Packagist | From 11.0.0 | 11.3.1 |
typo3/cms Packagist | From 9.0.0 | 9.5.28 |
typo3/cms Packagist | From 9.0.0 | 9.5.28 |
Products include Typo3 Typo3.
How do I fix CVE-2021-32668?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.18, 11.3.1, 8.7.41 or 9.5.28.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-32668 being exploited?
There is no known exploitation of CVE-2021-32668 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2021-32668, GHSA-6mh3-j5r5-2379.